Project

General

Profile

ENG frm #5846

Error27300 when install klhk driver. Error code: -2147024319

Added by Forum Synchronizer 8 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
3
Target version:
β-tester:
xzz123
Product:
KIS
OS:
Win 10, x64
Fixed in:

#1 Updated by Forum Synchronizer 8 months ago

xzz123:
<p>I again format my drive and clean installed OS, using iso from MSDN.</p>
<p>still got same error and error code.</p>
<p>Do you need any other data for investigation? Or is it worth I switch another OS build? </p>
<p><a href="https://cloud.qainfo.ru/s/wfxpcW6Ndj3qHec" target="_blank" rel="noopener">https://cloud.qainfo.ru/s/wfxpcW6Ndj3qHec&lt;/a&gt;&lt;/p>
<p>new gsi6 report, with installation logs in it.</p>

#2 Updated by Alexander Matrosov 8 months ago

Yingzhi Li (xzz123), Thank you. Passed new logs to the developers; waiting for an answer. <br>
Now no other data is needed

#3 Updated by Forum Synchronizer 8 months ago

xzz123:
<p>@jarvis</p>
<p>Hello </p>
<p>I did other test,</p>
<p>I successfully installed 2019 version on the exact same problematic machine. And it was indeed fucntioning normally.</p>
<p>But than I uninstalled 2019-reboot-install 2020, still got same error code.<img src="/plugins/nodebb-plugin-composer-kl/vendor/tinymce/plugins/emoticons/img/smiley-tongue-out.gif" alt="tongue-out" /></p>

#4 Updated by Forum Synchronizer 8 months ago

xzz123:
<p>Sadly report that I still can not intsall the latest build, build 454.</p>
<p>This time, it is the OS that can indeed install build 418 (see <a href="/topic/392/kfa-kav-kis-kts-ks-ksos-20-0-0-418/10" target="_blank" rel="noopener">here</a>) but than product failed to load. Now I completely lost the opportunity to join the beta test.</p>
<p>Here is gsi6 report generated from the problematic OS right after the installation failure.</p>
<p>https://cloud.qainfo.ru/s/kRrBs42bRcz2ADN&lt;/p>
<p></p>

#5 Updated by Forum Synchronizer 8 months ago

<p>Sadly report that I still can not intsall the latest build, build 454.</p>
<p>This time, it is the OS that can indeed install build 418 (see <a href="/topic/392/kfa-kav-kis-kts-ks-ksos-20-0-0-418/10" target="_blank" rel="noopener">here</a>) but than product failed to load. Now I completely lost the opportunity to join the beta test.</p>
<p>Here is gsi6 report generated from the problematic OS right after the installation failure.</p>
<p>https://cloud.qainfo.ru/s/kRrBs42bRcz2ADN&lt;/p>
<p></p>
<p>edit: Before the installation, I even use the removal tool to try unintall avp 19.. Also search registry for avp related and klhk, nothing found.</p>

#6 Updated by Yingzhi Li (xzz123) 8 months ago

the link to new gsi link seems not displayed properly, I direct add it in here
https://cloud.qainfo.ru/s/kRrBs42bRcz2ADN

#7 Updated by Forum Synchronizer 8 months ago

xzz123:
<p>Hello.</p>
<p></p>
<p>Finally, I found the answer.... It is the secure boot function of my laptop.</p>
<p>Device is  Thinkpad X240s, with new latest firmware v2.43 from <a href="https://think.lenovo.com.cn/support/driver/driverdetail.aspx?DEditid=18031&docTypeID=DOC_TYPE_DRIVER&osid=245&treeid=11275&args=%3Fyt%3Dpt%26categoryid%3D11275%26CODEName%3DThinkPad%2520X240s%26SearchType%3D0%26wherePage%3D2" target="_blank" rel="noopener">Here</a></p>
<p>with secure boot Enabled & UEFI only & CMS support off, Klhk.sys can not be installed.</p>
<p>After I disabled secure boot, installation finished successfully.</p>

#8 Updated by Forum Synchronizer 6 months ago

xzz123:
<p>Hello</p>
<p>Similar driver installation fail can be reproduce using latest build and an entirely different device.</p>
<p>with secure boot function enabled, product installation always ended up with same error.</p>
<p></p>
<p>windows10 RS5 17763.55 x64</p>
<p>kts20.0.0.607 en-us</p>
<p>Device: MSI GE60 2OC with secure boot enabled</p>
<p></p>
<p>Firstly, when I report this problem, I thought there may be conflicts between my thinkpad X240s uefi firmware</p>
<p>but when I try to install product in another device, the problem still reporiduced.</p>
<p>so I assume that: AVP can not be installed on any device with secure boot enabled.</p>
<p>I uploaded GSI with installation logs in it, report was generated right after installation failed.</p>
<p>also I uploaded screenshots about the error code(which is same as two months ago) and my uefi settings.</p>
<p><a href="https://cloud.qainfo.ru/s/BdOWxY2mUiOSKPv" target="_blank" rel="noopener">https://cloud.qainfo.ru/s/BdOWxY2mUiOSKPv&lt;/a&gt;&lt;/p>
<p><a href="https://cloud.qainfo.ru/s/hVGVsHioGWVS4B1" target="_blank" rel="noopener">https://cloud.qainfo.ru/s/hVGVsHioGWVS4B1&lt;/a&gt;&lt;/p>
<p></p>
<p>Dear KL</p>
<p>I beleive it is vital that you investigate this problem ASAP</p>
<p>During these days, I found some topics in business product section of kaspersky forum, user report they can not install product because of a fatal error,</p>
<p>which, share same error code.</p>
<p>you can check this one:</p>
<p><a href="https://forum.kaspersky.com/index.php?/topic/401614-kes-installation-fatal-error/" target="_blank" rel="noopener">https://forum.kaspersky.com/index.php?/topic/401614-kes-installation-fatal-error/&lt;/a&gt;&lt;/p>
<p>there is no remains of kl drivers but install still fail</p>
<p>and here</p>
<p><a href="https://forum.kaspersky.com/index.php?/topic/402331-endpoint-security-11-for-window-installation-fatal-error/" target="_blank" rel="noopener">https://forum.kaspersky.com/index.php?/topic/402331-endpoint-security-11-for-window-installation-fatal-error/&lt;/a&gt;&lt;/p>
<p><a href="https://forum.kaspersky.com/index.php?/topic/402278-install-faild/" target="_blank" rel="noopener">https://forum.kaspersky.com/index.php?/topic/402278-install-faild/&lt;/a&gt;&lt;/p>
<p></p>

#9 Updated by Forum Synchronizer 6 months ago

Helios_07:
<p><strong>Windows 10 64-bit, Version 1809</strong></p>
<p><strong>KIS 20.0.0.607 de app + drv verifier enabled</strong></p>
<p><strong></strong></p>
<p><strong>Also got Error 27300 when i tried to install KIS 20.0.0.607 the first time, after another reboot KIS installed normaly.</strong></p>
<p><strong>KIS setup logs+ screenshot of error: https://cloud.qainfo.ru/s/d9NOW1IXo15HnaE&lt;/strong&gt;&lt;/p>

#10 Updated by Forum Synchronizer 6 months ago

<p><strong>Real System:</strong></p>
<p><strong>Windows 10 64-bit, Version 1809</strong></p>
<p><strong>KIS 20.0.0.607 de app + drv verifier enabled</strong></p>
<p><strong></strong></p>
<p><strong>Also got Error 27300 when i tried to install KIS 20.0.0.607 the first time, after another reboot KIS installed normaly.</strong></p>
<p><strong>KIS setup logs+ screenshot of error: https://cloud.qainfo.ru/s/d9NOW1IXo15HnaE&lt;/strong&gt;&lt;/p>

#11 Updated by Forum Synchronizer 6 months ago

xzz123:
<p>your are luckly</p>
<p>I can not install the product use any method</p>

#12 Updated by TFS Synchronizer 6 months ago

Duplicate

#13 Updated by Forum Synchronizer 6 months ago

phantom:
<p>there was also an installation issue with error code 27300 and a secure boot in UEFI is also enabled on the PC</p>
<p>https://cloud.qainfo.ru/s/G6wUY6CB3rgc35o&lt;/p>

#14 Updated by Forum Synchronizer 3 months ago

xzz123:
<p>I can still reproduce this problem with secure boot enabled. Same error code.</p>
<p>Can you give more Detailed explanation about the issue?</p>
<p>As far as I can tell, it is a big problem and stable reporduce using any of my devices.</p>
<p></p>
<p><a href="https://cloud.qainfo.ru/s/epRQ1vBET3MOlmh" target="_blank" rel="noopener">https://cloud.qainfo.ru/s/epRQ1vBET3MOlmh&lt;/a&gt;&lt;/p>
<p>logs from new installer.</p>

#15 Updated by Forum Synchronizer 2 months ago

xzz123:
<p>Hello</p>
<p>Same problem reproduced with latest build: <span>20.0.10.954 RC</span></p>

#16 Updated by Forum Synchronizer 2 months ago

Dmitriy.Pisarets:
<p>@xzz123 can you add new installer traces, please? I'll reopen bug</p>
<p></p>
<p></p>

#17 Updated by Forum Synchronizer 2 months ago

xzz123:
<p>@dmitriy-pisarets</p>
<p>I just disabled secure boot and the installation was successfull.-----Just in oder to check another bug,</p>
<p>I will reproduce this one next day, it is very late in my here.</p>

#18 Updated by Forum Synchronizer 2 months ago

xzz123:
<p>@dmitriy-pisarets</p>
<p>here are new installation logs and GSI6 reprot with windows event logs included.</p>
<p><a href="https://cloud.qainfo.ru/s/0OiHM394YDD1iFm" target="_blank" rel="noopener">https://cloud.qainfo.ru/s/0OiHM394YDD1iFm&lt;/a&gt;&lt;/p>
<p></p>
<p>Device: Thinkpad X240s with latest BIOS & secure boot enabled & CSM disabled</p>
<p>OS: windows10 2016LTSB 14393.2670 x64</p>
<p>OS language: Simplified Chinese</p>
<p></p>
<p>The problem has long history, and it is highly likely to be reproduced on some of those old devices. </p>
<p>with old 4th generation CPU, legacy default boot option. After you turn to secure boot and uefi, product install will fail.</p>

#19 Updated by Forum Synchronizer 2 months ago

xzz123:
<p>I am going to get a new laptop, will not hold those old devices for long.</p>
<p>Please, investigate the problem, before I can still offer you logs and data.</p>

#20 Updated by Forum Synchronizer 2 months ago

Dmitriy.Pisarets:
<p>@xzz123 thank you.</p>
<p></p>

#21 Updated by Forum Synchronizer 2 months ago

Dmitriy.Pisarets:
<p>@xzz123, i got answer from developers: our drivers are not signed now. When 2020 will be released, secure boot will not crash our installer. You can try install 19 version and install it with secure boot. It'll work. </p>
<p></p>
<p></p>

#22 Updated by Forum Synchronizer 2 months ago

xzz123:
<p>@dmitriy-pisarets</p>
<p>So that is the reason.....wow, it worrys me for nearly half a year</p>
<p>the good news is that we finally get a happy ending. Better than never getting an answer.</p>
<p>You may close the case.<img src="/plugins/nodebb-plugin-composer-kl/vendor/tinymce/plugins/emoticons/img/smiley-smile.gif" alt="smile" /></p>

#23 Updated by Forum Synchronizer 2 months ago

Dmitriy.Pisarets:
<p>@xzz123 bad, that we didn't provide you info much more earlier. </p>


Description

<p><strong>Reproduction steps:</strong></p>
<p><span></span>Install KIS2020.0.0.418 en-us on win10</p>
<p><strong>Actual result:</strong></p>
<p><span></span>Install failed</p>
<p><strong>Expected Result:</strong></p>
<p><span>Installation is success, product loaded normally</span></p>
<p><span></span></p>
<p><span>OS: Windows10 Enterprise 2016LTSB 14393.2248 x64</span></p>
<p><span>Product Build: KIS2020.0.0.418 en-us</span></p>
<p><span></span></p>
<p><span>This OS is just newly installed, with few third party software.</span></p>
<p><span>but I can not install avp, I have tried twice. Got same error code.</span></p>
<p><span></span></p>
<p><span>Uploaded:</span></p>
<p><span>GSI6, install logs, error screenshot</span></p>
<p><span>https://cloud.qainfo.ru/s/V64MGHfLgV3KdEa&lt;/span&gt;&lt;/p>

Also available in: Atom PDF